Quantcast
Channel: SQL Server Database Engine forum
Browsing index pages (5123 articles)

SQL Server Crash

Hello,Our database unexpectedly shutdown, SQL Server version:Microsoft SQL Server 2017 (RTM) - 14.0.1000.169 (X64)   Aug 22 2017 17:04:49   Copyright (C) 2017 Microsoft Corporation  Enterprise Edition...

View Article


Image may be NSFW.
Clik here to view.

what's actually CMEMTHREAD

https://www.sqlskills.com/help/waits/cmemthread/what's actually "TREAD-safe-memory-object" ?

View Article


Image may be NSFW.
Clik here to view.

Transaction Log recovery phases

https://docs.microsoft.com/en-us/azure/azure-sql/accelerated-database-recoveryI am not quite sure the design for Phase 2 Redo , why it's not start scanning from the last commit lsn ?

View Article

Image may be NSFW.
Clik here to view.

differences in the query plan xevent ?

what's the following difference ?

View Article

SQL Server Crash

Hello,Our database unexpectedly shutdown, SQL Server version:Microsoft SQL Server 2017 (RTM) - 14.0.1000.169 (X64)   Aug 22 2017 17:04:49   Copyright (C) 2017 Microsoft Corporation  Enterprise Edition...

View Article


Performance of the database when I modify the MAXDOP parameter

Hi all I don't understand the behavior of the database when I modify the MAXDOP parameter. We have modified the MAXDOP parameter (from value 0 to value 4) to improve some processes with a quite good...

View Article

Default trace was stopped because of an error. Cause: 0x80070057(The...

Hello, We have MS SQL server 2016 Enterprise (SP2-CU5). After starting the server, the default trace file grows to 20 MB, and then stops with this error in ErrorLog:Trace ID '1' was stopped because of...

View Article

Image may be NSFW.
Clik here to view.

TDE with Keyvault

I am reading this DOC....

View Article


Image may be NSFW.
Clik here to view.

How to interpret Native Compilation Advisor report

so which code is blocking this procedure to natively compile 

View Article


Image may be NSFW.
Clik here to view.

Online rebuild index

for online rebuild index , I am reading the following linkshttps://docs.microsoft.com/en-us/sql/relational-databases/indexes/how-online-index-operations-work?view=sql-server-ver15And see if which part...

View Article

sys.dm_tran_version_store : version_sequence_num

In what chances that version_sequence_num will increase ?when two transaction update two separate row of the table, it should only generate to records on table  sys.dm_tran_version_store with...

View Article

Image may be NSFW.
Clik here to view.

Row estimation for query using variable

I have a table CREATE TABLE BillingInfo( ID INT IDENTITY, BillingDate DATETIME, BillingAmt MONEY, BillingDesc varchar(500)); ALTER TABLE BillingInfo   ADD  CONSTRAINT [PK_BillingInfo_ID]   PRIMARY KEY...

View Article

Image may be NSFW.
Clik here to view.

MEMORY BROKER

Hi Allhttps://docs.microsoft.com/en-us/sql/relational-databases/system-dynamic-management-views/sys-dm-os-memory-brokers-transact-sql?view=sql-server-ver15what's the memory broker that monitor the...

View Article


virtual_memory_committed_kb from sys.dm_os_memory_clerks

Can anyone tell what's virtual_memory_committed_kb from sys.dm_os_memory_clerksvirtual_memory_committed_kbbigintSpecifies the amount of virtual memory that is committed by a memory clerk. The amount of...

View Article

PolyBase : Access Data in cosmodb using mongodb fails with error

Hi All,I am trying to access data in my azure cosmosdb  using SQL Server PolyBase (cosmosdb was created using "Azure Cosmos DB for MongoDB API) I am able to connect and access documents using mongo...

View Article


SQL Licencing for Training databases

I have couple of databases that are used for training classes  every now and then,,   do i have to host these on a prod server  with SQL licence  or can they be treated as a non prod  Databases ?

View Article

auto update stats : sample

Are there any threshold that the auto update stats will use FULL scan or default sample size ?I see some small tables, (around 10k rows), will trigger auto update stats with full scan. 

View Article


PSSDIAG Output

Hi Team,Just curious to know that, Generally what tools Microsoft use to Analyze PSSDIAG Output.

View Article

Incremental Stats partition level statistics are not used by SQL Server CE

We can do the UPDATE STATISTICS [WideWorldImporters].[Sales].[CustomerTransactions](CX_Sales_CustomerTransactions) WITH RESAMPLE ON PARTITIONS(3) on serveral partition . And the results should be...

View Article

SQL Server resource pool MAX_MEMORY_PERCENT

MIN_MEMORY_PERCENT and MAX_MEMORY_PERCENTThese settings are the minimum and maximum amount of memory reserved for the resource pool that can not be shared with other resource pools. The memory...

View Article
Browsing index pages (5123 articles)


Latest Images